Previous Entry Share Next Entry
OS X 10.5 font woes
dead mac
nmg

Since moving to a Mac a bit over a year ago, I've had only a few reasons to look back (the business with the HP LJ1022 printer being one of them). I'm now rather close to the end of my tether, and the reason is fonts.

As an academic and a computer scientist, I end up writing quite a lot of papers and presentations with maths in them. Like any sensible person, I use LaTeX for typesetting the maths; it's a lot easier to type $\sum_{i=0}^{i=n-1} i^2$ than to wrestle with the equation editor in Word. I've also been using LaTeX for rendering mathematical expressions in lecture slides; there are two tools - LaTeXit and LaTeX Equation Editor - which make putting maths in Powerpoint or KeyNote a drag-and-drop operation.

However, I've spent quite a lot of time over the last week trying to debug a problem with the font rendering of TeX-generated PDF files on OS X. If I wrote a LaTeX file containing the following:

\documentclass{article}
\begin{document}
\section{This is a test}
\[e = mc^2 \rightarrow \chi \pi \ldots r^2 \]
\end{document}

then I'd expect it to render something like this:

Preview renders it like that, but not reliably - perhaps one time in eight. The rest of the time, it randomly substitutes a sans serif font for the various Computer Modern fonts. Sometimes it looks like this (missing the italic font):

Sometimes it looks like this (missing the bold and italic fonts):

And sometimes it looks like this (missing the bold and symbol fonts):

It isn't predictable which rendering I get. The problem also isn't limited to CM, but appears whenever you have a subset of a Type1 font embedded in PDF (on my machine, at least); TeX isn't the problem. The problem didn't exist on 10.4. The best guess from the Mac communities is that it's a cache corruption problem with the OS X PDF-rendering component on 10.5 (which would explain why I see the same problem in LaTeXit, LEE and Papers, but not in Acrobat).

I really don't see how Apple could have let a release out of the door with a bug like this - this is surely a critical bug for anyone in publishing.

Edited to add links:


  • 1
I really, really wouldn't advise running any command which combines sudo, rm -rf, and backticks. Especially off the Internet.

Hey, I did it and my Mac still works okay! Well, apart from the thing with the fonts and everything...

  • 1
?

Log in

No account? Create an account